Bug - Incident Stages Attachments (due for 20th March)


We can’t call the filed attachments in the incident stages anymore. it works for attachments on the incident itself, but not for the ones witihin each stage. There is just the error message “page doesn’t exist” (it links to e.g. …/securityIncidentStagesSecurityIncidents/downloadAttachment/50).
When debugging is turned on the following error is shown:


Morning Fabian,

Cant test this as i did not have existing attachments (on release #32, i tested uploading attachments on stages and it worked well) on our incidents stages, but before i raise a dev case, can you make sure your access lists are updated (System / Settings / Access Lists) ?


Just so we are clear, when Access Lists are not updated they look like this (i just had to update a system)


Yes they were updated after the release.
I checked again, and cleared the cache again to be sure. Still the same error.

And its a bug


Next monday we’ll release a hotfix. thanks Fabian!