Bug - Reviewing policy attachments breaks Eramba? (due for r37)

After reviewing a policies attachments I’m no longer able to click anywhere on the Eramba app. I have to refresh the page to use it. This only started after the latest update. I’m using attached policies and Chrome. Things get even weirder in IE where the page gets a black overlay and and never ending blue spinning wheel. Seems to work fine in FireFox. I’ve tried rebooting my PC and the web server.

Steps to re-create.

  1. Control Catalog > Security Policies
  2. Pick a policy > Manage > Reviews
  3. Click attachments.
  4. Do nothing, and click the Close button.
  5. Repeat steps 1-4 at least once.

The webpage will stop functioning.

Very strange, we could not replicate it. Have you updated the ACL after updating to r36? System / Settings / Access Lists - can you share a screenshot on how that looks?

does that happen only on Security Policy reviews and every time you open attachments and click the close button?
If you haven’t done this already, try also clearing your browser’s cache and application cache from Settings menu. After this is done, let us know if it starts working again.


I haven’t found it occurring anywhere else yet but I’ve really only been working the the policy section. I tried rebuilding my ACL, clearing the websites cache, and clearing my browsers cache to no avail. The issue occurs in Chrome incognito mode as well. MS Edge and Firefox work fine.

The view in Chrome looks normal. I just can’t click on anything. It’s as if the loading overlay doesn’t disappear.

IE 11 is also broken. See screenshot below.

Hi Dominic,

We dont think this is a bug (meaning everyone is affected) because we could not reproduce it, so we’ll look more at your specific setup. For that reason i’ll drop you an email from our support email to follow up there, once we find the issue we can take it back here.

I’ll drop you an email in a minute

This is a bug, it was not easy to reproduce ! thanks Dom for the help, this will be corrected on release 37 (since its not blocking a functionality)

1 Like

Was this fixed in r37? I’m still experiencing the issue post update.

this should have been fixed already, is this still an issue for you? Make sure your browser cache is cleaned and if you still see this issue, let us know and we will resolve it ASAP.