Bug - Dropdown custom field set as "Mandatory" does not support "0" value


Note that it seems that I cannot attach any images as I am a new user. You will have to do without screenshots.

We are using Eramba Enterprise, version 3.23.1. We noticed an issue with a Dropdown Custom Field we created in the Internal Controls → Audits Section. Our Custom Field has multiple numeric values for the users to pick from. One of these values is zero (0). When zero (0) is pick, we are getting the following error message: “This custom field is mandatory”. You can see that on the below screenshot:

We have tried to reproduce the same behavior on the other Custom Field’s types within the Internal Controls → Audits Section. When zero (0) is inputted as a value for any type of Custom Field (i.e., Short Text, Paragraph, Dropdown, Integer, and Float), the same error message as the one mentioned above is printed “This custom field is mandatory” (we did not specifically test for the Type Dropdown - Multiple Select as we assumed the same behavior as Dropdown). You can see that on the below screenshot:

Steps to reproduce the behavior:

  1. Go to “Control Catalog” → “Internal Controls” and create a dummy control with internal audits.
  2. Go to “Control Catalog” → “Internal Controls” → “Audits”.
  3. Click on “Customization” → “Add New Field”
  4. For “Type” select “Dropdown” (but as shown above, any available Type should behave the same way). Toggle “Mandatory”.
  5. In “Control Catalog” → “Internal Controls” → “Audits”, locate the Audit related to the dummy control created in Step 1 and click on “Edit (Complete Missing Audit)”.
  6. Fill all the mandatory fields and input “0” in the Custom Field you created in step 4. Then click on “Save”.

Expected results: the message “This custom field is mandatory” should appear.

Thanks for the support and have a nice day.

Thank you for the nicely written case. We are creating an issue.

Int. ref.: https://github.com/eramba/eramba/issues/4640

1 Like

Thanks a lot.

didnt know what, you get an error from the forum? could not find an option that blocks that.

you are by far the person that reproduces testing best in the history of eramba. you are correct this is a bug:

github: https://github.com/eramba/eramba/issues/4640


Thanks for providing a screenshot.

I edited my initial post; I was able to add one image. I believe that when I wrote the first version of this thread, I got a message saying something like “Sorry, new user cannot embed external attachments.”. However, I got a message this morning saying “Sorry, new user can only embed one external attachment per post.”.

I might have misread yesterday when I first wrote the thread.