Bug - Filters routinely don't save changes

I’m trying to use the Manage Filter button to create and modify filters. I go through the various tabs for the filter and make changes. Sometimes I hit the Filter button to see the results. Other times I hit the Save button to update the filter.

In both cases (hitting Filter or hitting Save) often times, my changes are not reflected or not saved. I have to go back in and try again. Sometimes Save will work when Filter doesn’t. Other times Filter will work when Save doesn’t.

How can I get my selected changes to be reflected on the first try, or is this a bug?


thank you for giving us notice about this issue. Its a bug and we will fix it.



I think I marked this as Solved to quickly.

I was just trying to modify a filter in Account Reviews. I changed a Status filter from Failed Must be No, to Failed Must Be [Not specified] to effectively remove the criteria. I hit the Filter button to see the results, but the filter still indicated it included Failed Must be No.


Maybe you’ve already prepared the fix but it hasn’t been released yet? Its hard to tell since I can’t see the GitHub links.

Yes , is not fixed yet !

We fixed this in release 2.7. If you already updated to latest version can you confirm the issue is fixed?

I’ll have to check in a couple weeks. I’m in the midst of Account Reviews and don’t want to perform an update at the moment (maintain stability).

I’m very much looking forward to this fix and will let you know as soon as I can.

P.S. Sorry for the delayed response. I got an email with your message, but when I tried to reply to to the email it got rejected. I didn’t realize I was responding to a post which couldn’t accept replies.