Bug - Issue setting public address

Going through setup guide and trying to set the public address. (“System” / “Settings” / “Public Address”.) I’m inputting the same URL that is being used to access Eramba and it’s throwing the error " Warning Connection is not accessible. If you save this you may cause this application to become broken or unreachable."

I’m not sure what I’m missing here. Address is in the format of https://eramba.domain.org and clicking fill from browser it still doesn’t work. Doing a lookup on the server via CLI the URL does in fact resolve properly as well so that’s not it. Anyone have a place to t-shoot this? If I add the :8443 it also doesn’t work.

I don’t really want to proceed with further until this is resolved.

I appreciate any help!

App Version: 3.16.2 | DB Schema Version: 20220921113150 | Community

Eramba gives me the same error on this screen, but it is expected in my case. We host the service behind a reverse proxy, so the public DNS name does not reference the IP address of the Eramba host.

If you have access to the CLI, then you can always configure this setting from the console should you lose access to the web UI.

1 Like

there might be a bug here with the web-interface, i believe the issue is: https://github.com/eramba/eramba/issues/3921

this will be fixed by the end of next week when we plan to make a release…plan, meaning next week or the week that follows

1 Like

Thank you!!

1 Like

Following, as I appear to have the same issue.

I can log in but then get connection fails. If I add :8443 to the end of the URL it works and I can browse through the menus, sometimes I have to re-add the :8443.

But if I go to a page like system|users the page will load but not the userlist as that is fetched via a js call and I can’t see how to add the 8443 into the address used by the script.

In the public address field if I put :8443 that fails on running the test.

This worked fine until I was going through all the settings to see what they all did and when I clicked “get from browser” that’s where the problems started.

@kisero That github link is giving me a 404, as does any search for the eramba/eramba repo

Thanks for reporting. A fix for this issue is planned for 3.17.0, as Esteban wrote in a previous reply.
We will also test this scenario.

Thank you for the link. :+1:

I’m not sure of the nature of this bug but my installation seemed to work OK before I set the public address. Is there a way I can undo setting the public address, eg a direct database change, so that I can continue to configure / use my eramba whilst waiting for the fix? The public address is not something I need at this point.

So in this case, navigate into eramba/app/upgrade and run

bin/cake settings set PUBLIC_ADDRESS NULL