Bug - MySQL 8.x Compatibility (community)

It seems ew have issues with MySQL 8.x:


When comparing DATE values with constant strings, MySQL first tries to convert the string to a DATE and then to perform the comparison. When the conversion failed, MySQL executed the comparison treating the DATE as a string, which could lead to unpredictable behavior. Now in such cases, if the conversion of the string to a DATE fails, the comparison fails with ER_WRONG_VALUE. (Bug #29025656)

the error log will show something like: Error: [PDOException] SQLSTATE[HY000]: General error: 1525 Incorrect DATE value: ‘’

int ref: https://github.com/eramba/eramba_v2/issues/2585

Hey folks… Trying to install a new instance of the community release on Ubuntu 20.04… MySQL 8.0.28 and PHP 7.4.3.

I’m running into issues that link similar to this. I know the enterprise certain doesn’t have issues with this config, but I’m wondering if the community version is older and has not had the updates for MySQL V8 applied.

Can anyone confirm if community is compatible with V8?

Yes unfortunately community does not have the patch yet.
You will need to downgrade the MySQL version.

Thanks, Sam!

It looks like I am still having an issue with certain aspects of the community version, even after a fresh install using Ubuntu 20.04 and MySQL 5.7. Specifically, if I run into issues with AD authentication. In troubleshooting, I turn on debug logging and browse to the LDAP connectors screen. I get the following errors and the connectors will not display (just spins and waits).

Everything else appears to work fine. So, I am just wondering if there are other known compatibility issues with the community release, given its age. For example, I am running PHP 7.4.3.

Again, this is with MySQL 5.7.37

And PHP 7.4.3…
Eramba - PHP (CLI)

For what it’s worth, we are enterprise customers. However, I need additional “test” environments to help train our team.

I appreciate any help you can offer.


The problem is that it won’t load? Is there something in the error log, too?
From what we know there should not be an issue with LDAP. Maybe it would be a good idea to try also with php7.3.
When you purchase an enterprise license you get two client keys for prod and test instance. Do you need additional instance?

Thanks, Sam.

I was able to configure LDAP fine on the install using MySQL8. However, user details (like the name, email address, etc) would not populate when I added the user and, when I tried to login, it would fail. I wasn’t seeing any errors, so I enabled debug logging, then got the issue I showed above. I went ahead and downgraded MySQL and I continue to get the errors shown above with debug logging enabled. I actually haven’t tried moving forward to testing authentication, since that error seemed to be the same and stops me from configuring the LDAP connector if I have debug logging enabled. I’ll try disabling debug logging and test actual authentication.

In terms of our needs, this is really for allowing my team their own playgrounds. I want them to be able to get comfortable with the UI, the relationships, etc. and I figured the community version would be the easiest way to do that.

Also, we are looking to become a partner and will probably want to quickly standup community instances for POCs. The VM doesn’t always work due to virtual hardware compatibility issues or different hypervisors. So, if we can get the community install working well, we’ll probably do that route.

I was testing with the same setup (php7.4 and MySQL 8). This is also the setup we have on demo.eramba.org
and it works perfectly fine. So there must be some other problem.
On system health, do you have everything correctly configured? All is ok?
Maybe you can send us error logs to support@eramba.org, maybe we will see something there.


We were able to get things working. We still get errors on the UI if we enable debug logging, but the actual authentication works.

Thanks for the follow up!