Bug: System Health Check messages not updated for PHP 8.1

Hi folks,
we successfully updated our Eramba test environment to e3.13.0 and PHP8.1.

However Eramba’s System Health Check is giving 4 warnings about things we need to tweak in the PHP.
The problem is: my infrastructure guys are telling me the file locations referenced in these messages seem to have changed in PHP8. Could you confirm?

  • Max Upload Filesize In order to upload large files you need to set upload_max_filesize to 8M or more. You can find this setting on your php.ini (under /etc/)

  • Max Execution Time We require setting max execution time to be equal or more than 200 seconds. You can find this setting on your php.ini (under /etc/) file under the setting: max_execution_time

  • Memory Limit We require setting memory limitations to be equal or more than 2048M (MG). You can find this setting on your php.ini (under /etc/) file under the setting: memory_limit

  • Max Input Vars We require setting max input vars to be equal or more than 3000. You can find this setting on your php.ini (under /etc/) file under the setting: max_input_vars

Hello,

If you are using ubuntu distribution, there are different php.ini for cli and apache or even fpm.
Make sure that you have it correct in all of these php.ini files.

OK :). My point is about the text for the System Health Warnings though…

You will find the settings in the relevant ini files under the following areas, and both php.ini files will need to be the same:
Apache: /etc/php/8.1/apache2/php.ini
Cli: /etc/php/8.1/cli/php.ini

Yeah - I’d think it would make sense to present two columns for the health check in the PHP section → one for web (Apache/NGINX/whatever) and one for CLI.