Feature - Rename "Security Policies"

We use Eramba for Compliance management also for other than 27001 standards and norms.
For this reason it could be good to rename “Security Policies” to “Documents library” or “Security related documents” or “Security documents”.
There are placed not only policies and some time the new Eramba users asks about “where to find the project security related documents” or infrastructure topology there only security policies should be placed" :slight_smile:
It’s easy to deploy and also better for understanding.

Many thank in advance for implementation…
Oleg

2 Likes

I think that is a good suggestion. I my case I had renamed this section by creating a custom translation.

Regards,

correct, just use a custom translation (see the documentation, under Basic Configurations)

So it seems like I have to create second “english” language with only one word correction?
It looks somehow too complex :slight_smile:
Maybe I can change it in the files direct?

For this custome translation I’ve create an “English_Test” language, and prepared english_test.po file from default template with:
"


#: Controller/Component/MenuComponent.php:175
#: Model/Behavior/CustomValidatorFormBehavior.php:154
#: Model/Behavior/RiskBehavior.php:381
#: Model/Table/DataAssetsTable.php:373
#: Model/Table/GoalsTable.php:373
#: Model/Table/ProjectsTable.php:444
#: Model/Table/SecurityPolicyReviewsTable.php:357
#: AwarenessPrograms/src/Model/Table/AwarenessProgramsTable.php:935
#: Ldap/src/Model/Table/LdapConnectorsTable.php:589
msgid “Security Policies”
msgstr “Security Documents”


"

But in UI Menu I still see “Secuirty Policies”.
What is wrong?

Changing the code is against our terms and conditions … please use the translations

Sure and agree! But translation does not work :frowning:

May I please ask in details how you did it?
I’ve created second english language “English_test” and used default.pot template.
Then I’ve changed one only item (see above). But it still be same “Security Policies”, not “Security Documents” in the “Controls Catalogue” :frowning:
Any suggestions?
Thanks in advance,
Oleg

try refreshing the cache at system / settings / clear cache , perhaps the issue is there. i would be surprised if this would not work, is pretty common for users to use translations.

You’re right! It works now! Thanks a lot!
Solved! I Love Eramba :slight_smile:

One more point - “Security Documents” in the Side menu is OK.
What’s about Section name - it still same "Security Policies.
See the screenshot:
2022-07-04 23_40_05-Security Policies _ Eramba

Do I miss some translation in the file? I’ve translated all items with “Security Policies”, Cache is also cleared.

Hello,

This one is a little bit tricky haha. In .po file search for Security Policy:

image

then eramba makes it plural and uses it across the system:

image