IMPORTANT - PHP / (MySQL|MariaDB) Versions

Summary of minimum version you will need for 3.x:

  • PHP you need 7.4 (no 8.x, no 7.2, etc)
  • MySQL you need 8.x and above
  • MariaDB you need 10.2.20 and above

On release e2.2.27 , under System / Settings / System Health you will notice that the PHP and MySQL controls will show NOT OK if you do not meet the requirements above. You need these versions because they work on BOTH, 2.x and 3.x

Once you are in 3.x you will be able to upgrade again if you want to PHP 8.x

@sam looked at your daily crons authorisation requests (this is what your eramba sends every night to us) and out of the php version you send we know that our enterprise customers run the following php versions:

eramba 3.x runs only on versions above 7.4 so if you want to upgrade to 3.x you will need to keep this in mind before you click update…is also important to know that php 8 has many benefits so is totally worth the update

because you all are into security, i remind you of the following expiration dates for security patches on php.

the webhook we get from you every night:


{“execution_time”:“118.832”,“created”:“2019-12-31 00:00:01”,“completed”:“2019-12-31 00:02:00”,“status”:“success”,“url”:null,“message”:“Your CRON Job has been completed successfully”,“cron_type”:“cli”}


Can it be confirmed if e2.20.6 or any version < 3.x compatible with php 8.0?

The Source Code - Install & Configuration Guide states the following as compatible PHP versions: 7.1, 7.2, 7.3, 7.4.


php 8.x is not fully compatible with 2.x , you might hit bugs

Currently, we are running PHP 7: 7.3.29-1+ubuntu18.04.1…will the upgrade support Ubuntu 20.04?


we try to avoid talking about if eramba works on one or another distro because in the end every distro chooses what default packages are put there and we dont keep track of it … but also that can be changed anytime with their respective package managers … in the end is php im sure you understand

as per ubuntu doc the default php is 7.4 Ubuntu – Software Packages in "focal", Subsection httpd , again that can be easily changed to 8

7.3 wont work!

1 Like