Question - Comments & Attachments notifications not working

I have Comments & Attachments notifications for Account Review Pulls, but I am not receiving any notifications when new comments or attachments are added to reviews.

hi !

could not reproduce the comment notification issue , i created a notification for comment, save it and put a comment on the first item:

then when i see the email queue (system / settings / queue) i can see the email there:

perhaps you are configuring the notification on a different tab? (top tabs)

Thanks for checking.

No, I’ve configured the correct section:

I’ve even checked Advanced Settings and confirmed they are turned on for all records. There are no prior emails sent for these notifications. Warning and Finding notifications are working fine, and I’m the Owner of all the reviews and the target of the Comments and Attachments notifications.

Going with the idea that I may still be using the wrong tab… If someone adds a comment/attachment on the Account Review Portal in response to a review, is that going to show up in the Pull tab or the Feedback tab?

If on the Feedback tab, I tried to create a Comment notification and none of the Custom Roles are available to select as recipients.

Appreciate your guidance.

[edit 2]
So maybe it is the Feedback tab where I need to create these notifications, as it seems to have worked, but again, there are no Custom Roles available. Also, the macros only allow me to reference the hex number associated with the pull, not the portal title or pull details, which would be much more useful information. Can these be updated with better options?

[edit 3]
Why does Account Review Feedback tab take excessively long to load/update? For instance, editing the Notifications for new Comments took 13.5 MINUTES to save. I figured my guesstimate would not do, so I timed it. Just opening the All Items filter with 7227 Results takes almost as long (I didn’t time that).

It goes on the account review feedback tab ! i see now you found that out by yourself.

correct, they are not there … this has something to do with this issue: int ref: , until that is done roles wont show up.

int ref:

This could have with the amount of data you have on the system and the filters you load by default when you load the section or it could be related with queries on the section not being optimised. Perhaps adjusting the section default filters and avoid listing “all items” (i think is the default) will help. That section is expected to have a lot of data.

int ref:

Actually, I do not use the All items filter often. I use a default filter to show items with Not OK or Not Sure (a much smaller amount); it is still excessively slow. Also, the issue affected just SAVING a notification, which took 13.5 minutes to complete.

We’ll look into it, saving takes nothing, what takes long is the loading after saving because content is no longer cached

Visually, the notification window that I try to save stays on the screen for the 13.5 minutes, so perhaps what you’re saying is accurate, but it looks like its stuck saving the notification. The results of my default filter are currently 0 records, but perhaps it takes so long to respond because of the lack of optimization you mentioned.