Question - Community on VMWare networking problems

Question - Community on VMWare networking problems

I’m trying to setup Community in my VMWare ESXi environment. I follow the instructions on, however I’m not able to open Eramba by going to the IP address. I can ping the IP address no problem, but getting to the login screen just errors out. Is there something that is missing in the instuctions on, or something I’m overlooking?


We have a new video on how to install eramba here: Docker Install - YouTube
Try to check, maybe it will help you.
You have to give us some more information to help debug the issue. We are not supporting community users but if there is something obvious we always try to help. Send us logs from eramba and apache to our support email and we might be able to help.

Thank you for the reply. I was trying to install VMWare one. I understand there is no support for community. I was trying community first to see how the install went. I’m looking to purchase Enterprise (I’ve submitted/filled out the “Buy Now” stuff), however, I’m not sure about it now based on the trouble I’ve experienced.

Is it recommended to do the Docker install versus VMWare install?

both work, since your post was created, some 20 hours ago, approx. 21 people around the world have installed community.

If you can not install eramba, perhaps this FAQ is useful: FAQs | Eramba learning portal

Thank you, but this does not help.

I have purchased Enterprise. Still waiting for my license keys.

In the meantime, I have continuously tried to install and setup Community in VMWare. I have followed your guide. I have set static IP.

No matter how I do it, cannot connect to login page (https://ip:8443) It just does not work.

verified the device has access to the update servers through curl

For some reason after running the docker composer, there is a new interface begins with br-.

Can you please share some output? Logs or screenshot, anything that can clarify the issue you are having.

editing /etc/netplan/50-cloud.yaml

composing docker

then running “docker logs -f eramba”, this never completes. never returns to shell

I test login screen:

one post would have been enough : )

Sorry, it would only let me do 1 screenshot per post. This was quickest way I could get them up.

I’m mostly working with Community for now making sure I’m able to do this with Enterprise without issue.

The strange thing is that I had none of these issues with the previous version of Community.

How are you running this VM? Is it running on an ESXi server or is it in VMWare workstation or Virtual box?
If it is the later, what networking options are you using? The reason I ask is that it appears that IP address of the server is a 10. address but the last login is reported as a 192.168 address. Not that this can’t work, but whenever I am looking at VM’s, I always worry about networking if I am using something like virtualbox.

Are you able to ping the 10 address from the your host machine? Just trying to eliminate issues with virtual networks.

Also please share output of docker ps -a

It is ESXi. It is on a VLAN. I am able to ping the 10 address. I worried it was networking as well. I know with Virtualbox and VMWare Workstation you have to set the interface to bridged. With ESXi, that’s not an option.

Can you also try the default VM as it is with the NAT adapter? From the eramba perspective, everything looks ok.
The problem lies somewhere between the docker engine and the network configuration of the host, for sure.
Also, please review the networking documentation of docker here.

First I would say you should not worry about the Enterprise purchase. I have had zero issues with support since my purchase.

Also, please keep in mind that this is 100% my own personal opinion and it should not be viewed as anything but the ravings of a (marginally) mad man.

At this point, I would go with the docker image if you have any familiarity with Linux at all. I am sure the eramba team has done a great job with the VM but I like to control the install myself so I know what has been installed, how the network is being managed and what hardening has been performed.

If you have done any docker before the install is very simple. If not, you can still get up and running with a minimal amount of effort. You can also explore other options this way like installing Portianer to manage the docker containers, for example.