Question - Community setup issues

Good morning everyone,

I am installing the community edition in order to evaluate Eramba before potentially switching to the enterprise model. I cloned the image yesterday and deployed it within “DockerDesktop”.
Unfortunately I still have 2 issues in my setup as per the Health Status page (I fixed 3 others, linked to the MySQL configuration but the health page was very instructive and helpful).

1) Worker Cron, not ok
I have the “NOT OK” status with the statement “Under System / Settings / Crontab Settings you can review the required crontab configurations.”
I looked at the guides and forum topics, and didn’t find any luck:

  • I tried the “touch /var/log/cron.log” followed by “chown www-data: /var/log/cron.log” that I found in a post, to no avail.
  • I also let a day pass, to see if the daily cron would fix it, and unsuccessful (and cron history has nothing)

2) MySQL - privileges
I have the following failure: “Connected datasource must have required permissions granted for the database to work properly. Required privileges: SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, ALTER, INDEX, PROCESS, TRIGGER.” with “Missing Privileges: PROCESS”
But when I looked at the db user, it seems ok:
mysql> show grants for ‘docker’;
| Grants for docker@% |
| GRANT USAGE ON . TO docker@% |
| GRANT ALL PRIVILEGES ON docker. TO docker@% |*

Could you give me some pointers?
Thank you to the community!

PS: I hesitated: please let me know if you prefer this post to be split in two.

Do you have your ‘public address’ set?

Hello Nick,
The git clone gave me Eramba version 3.20.

On this version, the public address seems to be populated from the .env file:


I left this value because I am still trying to evaluate the product.

My modal looks differently than yours. When I connect as “admin” to my Eramba instance, I see:

So it seems that the value is not empty for Eramba

1) Worker cron
While “docker logs cron” gave me nothing, I could navigate to /var/log/cron.log, and I read:

2023-06-16 20:47:01 error: [Cake\Database\Exception\MissingConnectionException] Connection to Mysql could not be established: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo for mysql failed: Name or service not known in /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver.php on line 133
Stack Trace:
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver/Mysql.php:164


Caused by: [PDOException] PDO::__construct(): php_network_getaddresses: getaddrinfo for mysql
 failed: Name or service not known in /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver.php on line 121
Stack Trace:
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver.php:121
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Core/Retry/CommandRetry.php:70
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver.php:131
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver/Mysql.php:164
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Schema/SchemaDialect.php:51
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Driver/Mysql.php:216
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Schema/Collection.php:53
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Database/Connection.php:418
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Table.php:520
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Query.php:290
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Query.php:184
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Table.php:1714
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Table.php:1269
- /var/www/eramba/app/upgrade/vendor/dereuromark/cakephp-queue/src/Model/Table/QueueProcessesTable.php:116
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Validation/ValidationRule.php:145
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Validation/Validator.php:2722
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Validation/Validator.php:275
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Marshaller.php:275
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Marshaller.php:191
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/ORM/Table.php:2787
- /var/www/eramba/app/upgrade/vendor/dereuromark/cakephp-queue/src/Model/Table/QueueProcessesTable.php:147
- /var/www/eramba/app/upgrade/vendor/dereuromark/cakephp-queue/src/Queue/Processor.php:330
- /var/www/eramba/app/upgrade/vendor/dereuromark/cakephp-queue/src/Queue/Processor.php:105
- /var/www/eramba/app/upgrade/vendor/dereuromark/cakephp-queue/src/Command/RunCommand.php:110
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Console/BaseCommand.php:189
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Console/CommandRunner.php:334
- /var/www/eramba/app/upgrade/vendor/cakephp/cakephp/src/Console/CommandRunner.php:172
- /var/www/eramba/app/upgrade/bin/cake.php:12

Could it be linked to the “PROCESS” issue then?

Please write to and we will do a quick call to review.

Hello Sam,

Sorry for the late answer. Here is a last update.
I cleaned everything and restarted from scratch 2 days ago:

  1. git clone

  2. I put the folder “docker” (and subfolders/files) as NOT readonly


  4. I browsed ALL files in the docker (sub)folder(s) and make sure the EOL were Unix compatible (that was the fix I did in the past when the cron container couldn’t execute

  5. curl is successful

  6. docker compose -f docker-compose.simple-install.yml up -d

  7. I stopped all the containers in DockerDesktop

  8. In sql container, I edited /etc/my,cnf by adding, under [mysqld]


(these were the suggestions from eramba health page)

  1. I started all the containers in DockerDesktop

>> Now the worker cron issue is solved as well as the “PROCESS” privilege one.

I had an “hourly cron” not ok in the health page, with nothing relevant in the cron history, But by the time I wrote down this reply, the issue has disappeared (it seems the hourly kicked in and resolved it)

So I am all good now!
I wonder what made the difference

  • did you update the community edition since 2 weeks ago?
  • or are my steps #2 and #4, done systematically this time (on all files) the reason it worked?

Anyway, you can close this thread, and thank you for the inputs !



Super that it worked. My bet would be that correct permissions before the first run of docker compose made the difference.