Question: Dashboard not loading (community)

Hello All,

We have recently installed Eramba community version. After performing the necessary steps and providing necessary information like Business units, internal controls, Security policies. I’m not able to view the Dashboard it kept on loading.

It’s been 1 month and it’s still saying:

“We are loading the dashboard in the background, you can use the system it will later on show up. Subsequent loads will be cached and load quicker.”

Kindly suggest the solution.


On system health everything is ok? This sounds to me like your cron is not running.

the Crons section of the System health says Not Ok. Should I configure it to make dashboard work?

Crons are configured by default. We need to find out why your crons are not running.
You can check if you have something in cron history. If no, it means crons are not running at all.
Most often the problem is that you do not have public address setup correctly.

There is nothing in the Crontab History. As far as public address is concerned yes, we have made our public address ip restricted.

I mean settings/public address

Ohh Okay, I configured the URL of my setup into the public address field. It’s throwing an error::

“Connection is not accessible. If you save this, you may cause this application to become broken or unreachable.”

could you provide me with troubleshooting steps for resolving this issue?

This is what we found and worked for us now on multiple versions. Get into the CLI of the server and run these commands:

sudo docker exec -it cron bash
–enter in the elevated password–
touch /var/log/cron.log
chown www-data: /var/log/cron.log

Thanks for the steps pal. Although System Health isn’t showing any error.

But still I’m not able to put the public address, it’s still throwing the error:

“Connection is not accessible. If you save this, you may cause this application to become broken or unreachable.”

Could there be some sort of DNS issue on your end assuming you don’t have it open to the whole internet?

Yes, it is for sure DNS and docker networking.
@puneet.chahar if you do not have experience with docker networking etc. I would say that the easiest way is to save there what you have in a browser (including port) even if test is not ok.

Thanks you @sam and @david.schroth the dashboard worked after I saved whatever I had in my browser including port.

i’m logging an issue to make public_url a setting that must be completed as part of the first login sequence

int ref:

1 Like