Question: Eramba Community - cron test

Hi all,

So i’m testing our eramba before my company purchased the enterprise version, but i’m having some issues with the cron test.

When I run the cron test I get the following error:

eramba@eramba:/var/www/html$ /var/www/html/eramba_community/app/Console/cake cron test
PHP Warning:  _cake_core_ cache was unable to write 'cake_dev_eng' to File cache in /var/www/html/eramba_community/lib/Cake/Cache/Cache.php on line 327
PHP Warning:  /var/www/html/eramba_community/app/tmp/cache/persistent/ is not writable in /var/www/html/eramba_community/lib/Cake/Cache/Engine/FileEngine.php on line 389
PHP Fatal error:  Uncaught CacheException: Cache engine "_cake_core_" is not properly configured. Ensure required extensions are installed, and credentials/permissions are correct in /var/www/html/eramba_community/lib/Cake/Cache/Cache.php:186

Initially I thought this was due to permissions, so i did:

chown www-data: eramba_community -R

However I get multiple errors that changing permissions is not permitted on the files.
Anyone got any hints on how to resolve this?


As I suggested in the email, you have to do both as a root user or with sudo.

I’ve done this with root user by using sudo -i then I ran:-

/var/www/html/eramba_community/app/Console/cake cron test

And it passed the message of:

All Looks OK

However, when I go to the system health, my daily cron jobs state “Not OK”

If anyone has any thoughts on this, and can steer me in the correct direction it would be appreciated.

This is from more recent enterprise install experience, which may differ from the current community edition → here’s what I’ve done → this assumes the daily is the issue on system health.

Actually two options.

  1. Wait until tomorrow, the daily cron will have run and you can declare victory.

  2. Force run the daily cron (not the test) by using “cake cron daily” (or, the whole thing → “cd /var/www/html/httpdocs/app/upgrade && bin/cake cron job daily”

Notes on #2 are - you’ll have to run it as root when you execute it, which will then change the file names of a few things potentially, so you’ll then fail the file ownership system check. Go back and chown everything and you should be good to go.

“test” does not reset your flags as far as hourly/daily/yearly being successful (though, yearly is set as good upon install, and the hourly likely set itself as good as you were tinkering and it ran).

Thanks David i’ll check it over the weekend and see how it goes then.

@david.schroth is correct.
Just additional info to 2.
You have to run this one:

Copy command directly from settings/crontab (path may differ on your instance)
su -s /bin/bash -c “” www-data is there to run in as an apache user and avoid problem with permissions.

Community will be updated soon, there are many differences between enterprise and community.

Thanks Sam,

And once i’ve been able to evaluate the community edition, we will certainly purchase the Enterprise version.