Question - eramba MySQL and PHP versions required? (due for 20th March)


On release #32 we included the following message on the release notes:

"IMPORTANT: In the next couple of months we’ll need all systems to run php7.x and MySQL 5.6.5 / MariaDB 10.1.x or greater. Please begin the required arrangements in your organisation to perform that migration. Contact for help if needed"

We have also included a health check that makes sure you are running MySQL 5.6.5 (if you sysadmins complain remind them MySQL 5.6.5 was released in 2012!) or greater and MariaDB 10.1.x as we realised that previous versions will soon no longer be supported by eramba. We gave notice of the need for PHP7 in January 2017 too.

Conclusion: eramba will still work with old MySQL / PHP versions, but not for much longer. Our guess is until the European summer. We strongly suggest you start the process of migrating eramba to a new, updated server that runs PHP7 and the latest MySQL / MariaDB version possible. The migration is really simply, is just copying files and MySQL databases - if you need guidance do let us know.

We are not trying to push things too much, we dont want to keep anyone out of course but we do feel we need to rush migrations otherwise we’ll have no other option!!

Keen to hear feedback!

1 Like

Thanks for the information.

It might lead to some effort for all RHEL users (like us). Red Hat is quite slow and cautious with upgrading versions and is still on MariaDB 5.5 and PHP 5.4 .The SysAdmin is reluctant to install the new packages from the RedHat Software Collection (other paths, own config files etc).
Head-ups are appreciated in order to convince my Admin :slight_smile: or maybe anyone knows the RHEL-roadmap??

Just a note on this, @yan.huard has spotted that our health check works for MySQL but not for MariaDB, this means that even if you have the latest MariaDB version you still get the warning message.


Perhaps this helps a little bit:

MySQL 5.4 is not supported:

PHP 5.x is no longer supported (only security updates until end of next year)

In our opinion, IT needs to service customers … simple as that. We need updated versions for functionality that did not exist 3 years ago, we dont mean to force anyone to use a version that is not “Stable”.

1 Like

No one should be using official RHEL/CentOS PHP builds. RHEL got lazy and stopped back-porting PHP fixes that were mitigated by other mechanism. If you don’t believe me run a Nexpose scan against you RHEL server and drill down into the reported vulnerabilities.

Instead upgrade to PHP7 using Remi Repo;