Question - How to Enable cron in Docker Container?

After upgrading community edition, Docker install, the system health report shows that cron is not enabled. How do I enable cron for the docker install?

1 Like

Crons are enabled by default. If crons are NOT OK in system health, the first thing to do is to look at settings/cron history, maybe they are finished with some error.
If you do not see records of crons, it means they are not running, you have to check logs there might be some more information about the problem.

Nick… were you able to resolve? I’m still trying to figure this out… I did the Docker community install from scratch and have not changed anything, but the health report shows:
Worker Under System / Settings / Crontab Settings you can review the required crontab configurations. - NOT OK

Hello,

Please go inside the cron container with the command:
docker exec -it cron bash
and then run these two commands:

touch /var/log/cron.log
chown www-data: /var/log/cron.log

The worker will start running the next minute.

1 Like

Thanks Sam! You are appreciated!

2 Likes

this path is not declared as persistant storage in the deployment script (compose file), which, if for whatever reason, will result in that file will be removed upon container restart - should that path be mounted as a volume?

Hello,

The problem was only with version 3.18.0, it was fixed with the hotfix 3.18.1.