Question - Missing logo in emails (Closed)


I’ve uploaded our logo in Eramba but it doesn’t get displayed in notification emails. I’ve notice that the email tries to fetch the logo using this URL : “https://eramba/settings/getLogo” . If I put it directly in a browser, it downloads the logo…

Any thoughts?



This could be a couple of things, but most likely is something to do with the URL you set on eramba. Your mail client might not be able to reach it and show that error. For security reasons, most mail clientes (web based and app based) will check content before is available to the user.

The best way to track this down is to have a look at your apache logs while you open an email on your mail client … chances are you wont see an entry on the log. Gmail is quite known for that (as it caches images before showing them).

Can you look at that?


ps. im careful stating “is not a bug for sure”, but on this one im %99 sure is not a bug.

Hi Esteban,

I think you’re right. I found the following instructions on how to set up internal images in Gmail : Set up an image URL proxy whitelist

We’ll test and I will let you know if it fixes the issue.


Cool doc from google - did not know that!

Good Morning,

I would like to reopen the topic with missing logos again.

My company is using Outlook 2013 as e-mail client and whenever I receive an e-mail from our local Eramba installation the logo can’t be displayed:

When I open this email in a browser (e.g. IE) the logo will be displayed. I already added the sender to the “safe senders” but without effect.

When I change the URL “” in the e-mail into like the Logo will be displayed in Outlook.

Does anybody have the same problems or maybe a solution?

Just so I understand the issue, when you open the email on a client (Outlook) it does not work, but if you open from a Browser (using Outlook webmail it does?) it does?

When i open an email from eramba (trouble is i use gmail and gmail as stated above caches images before you open the email) the url that contains the image is:

In apache, that request looks like this: - - [05/Jun/2017:08:01:41 +0000] “GET /settings/getLogo HTTP/1.1” 200 3213 “-” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36”

Can you check that you get those requests? Can your email client / browser get to that url ?

The issue is identified and solved :grinning:

The problem was the self-signed certificate we are using for the eramba-server. The certificate was configuered in our browsers as trusted so the logo was displayed (log entry was available). Our Outlook client had problems with this self-signed certificate so the eramba-server was handled as untrustworthy and the logo was not downloaded.

So thanks for your support.

Great !
Wish you a good weekend !