Question: Public Address: cant perform the cli command to Null public adress

I think i’ve saved the wrong public address onto eramba whenever I try to log on my ip address changes.
I tried to use the cli command : bin/cake settings set PUBLIC_ADRESS Null but it says No such file or directory
how do I perform the cli command?
Kind regards


From the explanation you provided, I’m not sure if you are running an on-premise or dockerized version. If you are running the dockerised version, you have to be inside the eramba container and in the folder eramba/app/upgrade.

I’m running an on-premise version using VMWARE workstation 17 i’ve done the installation using the ovf link.
Every thing was working perfectly until i saved the public address. When I reboot eramba the IPV4 address given is However when i try to login with my admin account the IP address changed to which was the old IP address.
The reason why i need to manually change the Public Address. But i am not able to execute the command on my VMWare

You have to execute it inside eramba container as I wrote before.
To do that, on your host, run command:
docker exec -it eramba bash
now, you are inside docker container, you have to go to eramba/app/upgrade folder
cd /var/www/eramba/app/upgrade
and now you can execute the command
bin/cake settings set PUBLIC_ADRESS NULL

Thank you sam,
I tried to run the first command it returns: got permission denied while trying to connect to the docker daemon socket at : unix:///var/run/docker

You have to execute it as a root user. Therefore:
sudo docker exec -it eramba bash

Thanks the command has worked but i’ve stumble on another problem.
I am able to access eramba from the chrome navigator but when i put my admin credentials in it says that the site is not accessible (ERR_CONNECTION_REFUSED)