Support - Cannot create schema in AWS RDS

I am able to create the schema when using a mysql installed on the same VM as eramba. But when trying to create the schema in an RDS mysql instance I get errors like:

ERROR 1227 (42000) at line 9597: Access denied; you need (at least one of) the SUPER privilege(s) for this operation

I have tried creating the schema with eramba user and also the root user. Both yield the same error.

This seems to be related to the DEFINER clause. I also see that ‘localhost’ is hard-coded in the schema (ie, DEFINER=`eramba`@`localhost`). My RDS eramba user is defined as eramba@% so I’m guessing that is a decoy?

Any idea what could be the issue?

From AWS

So it seems that the localhost being hard-coded in the schema is the issue.

Removing the DEFINER’s allowed for creating the schema. I’m guessing that when I upgrade via the UI all the schema updates will fail then?

1/ what are the grant priviledeges of the user that is connecting to the database?

2/ are all sql parameters configured on the rds engine?

ref: Source Code - Install & Configuration Guide - Google Docs

3/ is binary (replication) enabled?

4/ are you using a clean schema or is a dump from another server which was using eramba? if its an old schema you need to adjust the user on both (new and old db) to match otherwise the schema will fail.