V2 can't filter by Group

First post so be kind :slight_smile:

I recently upgraded to v2.x. All our assets, risks, projects etc are assigned to groups and not individuals. It makes it easier for notifications and when staff leave, changes roles etc.

I can no longer filter by owner, guardian etc where it’s been assigned to a group. This applies to any of the modules - risk, asset, projects etc. E.g. filtering projects where project owner = “information security (group)” returns zero records where I know the group has been assigned.

Any filter, including system filters do not display the owner, e.g., using All Items when viewing Projects.

When editing or running a item report, the group name displays.

I’ve tried removing and re-adding the group as an owner, adding a user in addition to a group and all ends with the same result.

no worries, thank you for your post i think you did find an issue. my test was:

  1. create an internal contorl, owner and collaborator are both a single user. saved the item.
  2. edited the control, edited the owner and put a group (the group has another user inthere called ross). saved
  3. the control is not showing the group on the index, that is a bug

  1. the filtering logic works tough, the control is shown to me even when im logged as “ross” (which belongs to the group). that leads me ot think the issue is just that the filter is not showing “groups” and only shows “users”

do i make any sense?

by the way, if this is not what you mean raise a ticket to support@ermaba.org (reference this post) and we’ll do a zoom call to quickly validate what is going on.

Yes, point 4 - filtering logic only showing users and not groups is what i’m experiencing.

It was working in v1.x.

Yep - we are about to release a fix now for this an other issues we found.
let us know if the problem persist after the release.